November 23, 2014, 06:49:40 PM

collapse

* 'Like' And 'Follow' Us!

* Nexus 7 News


* Who's Online

  • Dot Guests: 19
  • Dot Hidden: 0
  • Dot Users: 8
  • Dot Users Online:

Author Topic: Camera Still Not Working....  (Read 4287 times)

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Camera Still Not Working....
« on: August 27, 2012, 03:18:17 PM »
I've cried about this in another post but I've still not been able to figure out why, when I try to use the simple camera app that most folks are using, it always says "Unfortunatly, Camera has stopped."  I just don't think that it's the fault of the app, but what can I try to figure this out?  I loath to do some kind of a complete 'reset' so that I lose all my data, etc. or send it in to be looked at.  Any ideas what I can try to figure out why I can't play with my camdamera??

radio


Time flies like arrows... Fruit flies like bananas!

Offline JayJ

  • Android Jedi
  • Global Moderator
  • Hero Member
  • *****
  • Joined: Jul 2012
  • Location: Suffolk, England
  • Posts: 2100
  • Popularity: 73
  • Long term Android fan, long term A**le hater!!
    • View Profile
Re: Camera Still Not Working....
« Reply #1 on: August 27, 2012, 03:49:26 PM »
Your options are either manually find what files are missing and I can send you a copy to paste back into your system or flash the stock image, this will mean you'll need to back up everything including your internal memory because it will wipe your whole N7...
Nexus 5 stock rooted 4.4 Franco kernel

Nexus 7 FHD stock rooted 4.4

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Camera Still Not Working....
« Reply #2 on: August 27, 2012, 05:09:30 PM »
Your options are either manually find what files are missing and I can send you a copy to paste back into your system or flash the stock image, this will mean you'll need to back up everything including your internal memory because it will wipe your whole N7...

Thanks Jay; how do I go about looking for those missing files??

r
Time flies like arrows... Fruit flies like bananas!

Offline JayJ

  • Android Jedi
  • Global Moderator
  • Hero Member
  • *****
  • Joined: Jul 2012
  • Location: Suffolk, England
  • Posts: 2100
  • Popularity: 73
  • Long term Android fan, long term A**le hater!!
    • View Profile
Re: Camera Still Not Working....
« Reply #3 on: August 27, 2012, 06:56:20 PM »
Well what files have you deleted?

Have you just removed apps that you think aren't of interest to you or have you been snooping around the system files with a file explorer?
Nexus 5 stock rooted 4.4 Franco kernel

Nexus 7 FHD stock rooted 4.4

Offline birdastrompgman

  • Hero Member
  • *****
  • Joined: Jul 2012
  • Location: Bay Area, CA
  • Posts: 838
  • Popularity: 28
    • View Profile
Re: Camera Still Not Working....
« Reply #4 on: August 27, 2012, 11:53:59 PM »
Look through this list, radio. You should have all the files with the June build date. Ignore those with sda1 or sdext2 in their path. They're backups on my flash drive
« Last Edit: August 27, 2012, 11:57:27 PM by birdastrompgman »
Bird has seen >650 North American bird species
Rooted Nexus 7
49.5 mpg avg for 53k miles in non-hybrid Scion xB
Retired 9 yrs, and loving it

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Camera Still Not Working....
« Reply #5 on: August 28, 2012, 07:15:41 AM »
Wow thanks bamman, this is just what I need!  I'll check this out very carefully and let ya know what I find...  'cept, what program are you using to see those files??

r
« Last Edit: August 28, 2012, 07:25:32 AM by radiocycle »
Time flies like arrows... Fruit flies like bananas!

Offline birdastrompgman

  • Hero Member
  • *****
  • Joined: Jul 2012
  • Location: Bay Area, CA
  • Posts: 838
  • Popularity: 28
    • View Profile
Re: Camera Still Not Working....
« Reply #6 on: August 28, 2012, 08:29:57 AM »
I ran Root Explorer, and did a search from root for "camera," radio.  ES File Explorer would probably yield the same results.  Looking at the list again, I think you should have the Dec 69 files, too.  Your N7 should ship with basically all the listed files except those with Aug 2012 dates.  I added the Aug dated files by installing the MoDaCo Camera app, and fiddling with trying to get it running from my flash drive.
Bird has seen >650 North American bird species
Rooted Nexus 7
49.5 mpg avg for 53k miles in non-hybrid Scion xB
Retired 9 yrs, and loving it

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Camera Still Not Working....
« Reply #7 on: August 28, 2012, 04:45:06 PM »
Here's what I get birdman,  None of those 'android' files when I search for 'camera'.
Time flies like arrows... Fruit flies like bananas!

Offline birdastrompgman

  • Hero Member
  • *****
  • Joined: Jul 2012
  • Location: Bay Area, CA
  • Posts: 838
  • Popularity: 28
    • View Profile
Re: Camera Still Not Working....
« Reply #8 on: August 28, 2012, 06:33:59 PM »
Well, it looks to me like you have ll the necessary files, but you have added an app that handles camera uploads.  That may not have closed correctly.  So, force close the app and see if the MoDaCo camera launcher works. 

If that doesn't help, move your pictures from that app to your PC/Mac, delete the app, and try the MoDaCo camera launcher.  Also force close any other apps that might use the camera - photo editors, Skype, etc.

Have you tried uninstalling and reinstalling the MoDaCo camera launcher?  I'd try that, too.
Bird has seen >650 North American bird species
Rooted Nexus 7
49.5 mpg avg for 53k miles in non-hybrid Scion xB
Retired 9 yrs, and loving it

Offline S.Prime

  • PM if You have a Forum Issue
  • Global Moderator
  • Hero Member
  • *****
  • Joined: Jul 2012
  • Location: GA-USA
  • Posts: 1970
  • Popularity: 80
  • Galaxy S3-TPT-HTC Flyer-Nexus 7 & 10-Rooted 100%
    • View Profile
Re: Re: Camera Still Not Working....
« Reply #9 on: August 28, 2012, 07:04:16 PM »


With the ability to reinstall apps from Google Play, at this point why not just go with a factory reset? If rooted, you can then root again, install your apps, restore your data and you are done.
IT Service Professional - I just want a device to be productive.

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Re: Camera Still Not Working....
« Reply #10 on: August 28, 2012, 07:45:55 PM »


With the ability to reinstall apps from Google Play, at this point why not just go with a factory reset? If rooted, you can then root again, install your apps, restore your data and you are done.

But how do I restore my data?  From where?

r
Time flies like arrows... Fruit flies like bananas!

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Camera Still Not Working....
« Reply #11 on: August 28, 2012, 08:30:20 PM »
I don't really have any pics, music, or emails that I need to keep, the only data I'd like to have is the various points in games that I've reached.  Is it possible to do a factory reset and get all my AcrossAgeDX and Asphalt 7 data back??

I did try uninstalling and reinstalling the camera app, with no luck...

radio
Time flies like arrows... Fruit flies like bananas!

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Camera Still Not Working....
« Reply #12 on: August 29, 2012, 08:58:10 PM »
Well, I think I'll just live without the camdamera.

I can't bare to start over again with Asphalt 7, and I have my home screen set up so nicely with the HD weather widget etc.  It will still work with video, just no stills. 

radio
Time flies like arrows... Fruit flies like bananas!

Offline treee

  • Newbie
  • *
  • Joined: Sep 2012
  • Posts: 4
  • Popularity: 0
    • View Profile
Re: Camera Still Not Working....
« Reply #13 on: September 12, 2012, 09:13:47 AM »
Hi radio: did you get any further with your camera problem? Am asking because it sounds like the same thing as i'm experiencing, or if not, very similar. i've been searching for a while now, but haven't managed to find a solution. i know my camera worked at one point, because i used it for a skype video call. but it doesn't now.

When i try using the MoDaCo launcher, the framing area is just blank (I can't take a screengrab of it - for some reason that doesn't work).  Eventually i either get an error message popping up -  "unfortunately the gallery has stopped working" or "gallery isn't responding. do you want to close it?" - or the entire screen just goes completely black, other than 3 small grey dots at the bottom. Before this, I can switch between video & photo modes, but it's very, very sluggish and the framing area is always blank. Occasionally the video framing area goes completely white.

Sometimes, but not always, when I start up the MoDaCo camera launcher i get the error message "cannot connect to the camera".

If I try doing a video call in Skype, it fails to launch the video camera.

I can still open the Gallery independently, which shows a couple of other images of mine from G+ and Picasa.

I rooted the device when i first got it, but haven't installed any other roms or tweaked it in any other way. In fact i've done very little with it - i've only installed a handful of apps and I've been working backwards, uninstalling these one-by-one (including Skype), to see if any conflict is resolved but so far nada. I've tried reinstalling the MoDaCo launcher too, but that didn't help either.

If anyone has any suggestions, I'd be grateful.

Offline radiocycle

  • Hero Member
  • *****
  • Joined: Jun 2012
  • Location: Vallejo, CA
  • Posts: 653
  • Popularity: 9
    • View Profile
Re: Camera Still Not Working....
« Reply #14 on: September 12, 2012, 10:17:59 AM »
Hi treee and welcome to the forum.

Well, the error message that I always get is different than yours but the result is nearly the same.  The message I get is always, "Unfortunately, Camera has stopped".   It looks like you are on the right trail by systematically eliminating possible culprits.  I have ruled out a factory reset, as I don't feel like loosing various game progress, data, etc. so even though that *might* fix the problem, I've resigned myself to not having a camdamera on this device.  Good luck with yours!

r
Time flies like arrows... Fruit flies like bananas!